Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: troubles converting HDPVR TS files to MP4

  1. #1

    Default troubles converting HDPVR TS files to MP4

    I use a HDPVR to record TV shows off my cable box STB. The HDPVR creates TS files with H.264 video and AC3 audio. I use a program called GBPVR to control the HDPVR. These TS files playback quite well on my PC or when I stream them to a Network Media Tank.

    I have been trying to use VideoRedo to remux these files to be compatible with the iTunes and the new Apple TV 2. The resulting MP4 files play, but they have a sort of a shimmer or stutter.

    I open the TS file with VideoRedo, mark the start and end of the file to trim off what I don't want, then I click on the Save As button. I select the H.264 MP4 profile to save of the file.

    I've pasted the input file info as shown from doing a ctrl-L down below. The behavior I describe was from version 600. I also tried 606. The file that was generated by 606 was not seen as valid by itunes. I think this was related to the way 606 handles the default audio behavior for the H.264 MP4 profile. I created my own profile to get around the audio issue, but I still got the same shimmer/stutter issue. I noticed there is a 607 out now too. I can try it too, but I don't see anything mentioned that might address this issue in its fix list.



    File: Name : D:\Video\Recordings2\Bored to Death\Bored to Death_20101010_22002230.ts
    Size : 0.900 GB
    Duration : 00:31:56.44
    Mux type : TS Stream
    Video: Encoding : H.264
    VideoStreamID : x1011
    Frame rate : 59.94 fps
    Encoding size : 1280 x 720
    Aspect ratio : 16:9
    Header bit rate : 20.000 Mbps
    VBV buffer : 3050 KBytes
    Profile : Main/4.0
    Progressive : Progressive
    Chroma : 4:2:0
    Entropy mode : CABAC
    Bit rate : 3.609 Mbps
    Audio Stream: 1 (Primary) Codec : AC3
    Format : AC3 stream
    Channels : 2.0
    PID : x1100
    PES Stream Id : xBD
    Bit rate : 384 Kbps
    Sampling rate : 48000
    Sample size : 16 bits

  2. #2

    Default

    Try 607. If you still have the problem let us know.

    Dan
    Dan Haddix
    Developer

  3. #3

    Default

    I tried 607 too now. It's behavior seems very similar to 606. The first issue I have with either of these is that itunes does not think the MP4 file that is generated is even valid. I really think this is because the AC3 is not converted to AAC by default anymore as was done with 600. I thought if you stick AC3 in a MP4 file, it needs to have the M4V suffix instead. I know it is kind of fuzzy about whether it is OK to put AC3 in MP4 files.

    To get around this issue, I did force the audio to be converted to AAC by creating a new profile. The resulting file can be imported to itunes, but is not playable.

    I also notice the length shown by itunes and windows explorer on the resulting file is much longer than the actual video. My test case is a 30 minute tv show. The resulting MP4 file is shown as having a length 2 hours and 21 minutes.

    Here is the profile I am using to force the AAC audio.

    <VRDOutputProfile enabled="true">
    <Name>H.264 MP4 AAC</Name>
    <OutputMode>Smart</OutputMode>
    <FileType>MP4</FileType>
    <OutputLibrary>
    <Program>None</Program>
    <CustomPath></CustomPath>
    </OutputLibrary>
    <DefaultOutputDir></DefaultOutputDir>
    <VideoAttributes>
    <Encoder>H264</Encoder>
    <AspectRatio>No Change</AspectRatio>
    <AspectCorrection>None</AspectCorrection>
    <EncodeDimensions>
    <Width>1920</Width>
    <Height>1080</Height>
    </EncodeDimensions>
    <EncodeBitrate>0</EncodeBitrate>
    <HeaderBitrate>0</HeaderBitrate>
    <MaxBitrate>0</MaxBitrate>
    <ShrinkPercent>100</ShrinkPercent>
    <EncodingMode>SP</EncodingMode>
    <UseVBREncoding>True</UseVBREncoding>
    <DeinterlaceMethod>None</DeinterlaceMethod>
    <MaxGOP>0</MaxGOP>
    <FrameRate>No Change</FrameRate>
    <OutputNAVPackets>false</OutputNAVPackets>
    </VideoAttributes>
    <AudioAttributes>
    <Encoder>AAC</Encoder>
    <Bitrate>160</Bitrate>
    <SampleRate>No Change</SampleRate>
    <AllowMultiAudio>False</AllowMultiAudio>
    </AudioAttributes>
    </VRDOutputProfile>

  4. #4

    Default

    QuickTime will not play MP4 files with AC3 audio, but the AppleTV will. In fact Apple designed the standard for storing AC3 in the MP4 container specifically for the AppleTV.

    Have you actually tried playing the files generated by 607 on the AppleTV? You indicated that the output from 606 worked except there was some sort of shimmer. That's something that might have been fixed in 607. (there was a frame rate issue which specifically effects 1280x720 video which might have caused this)

    Dan
    Dan Haddix
    Developer

  5. #5

    Default

    I guess I am confused on how I would play a file on the Apple TV without first importing them into iTunes. As far as I know, that is the only way currently to stream your own content to the Apple TV 2. If you know of a different way, please let me know.

    Maybe there are way to trick itunes into importing these MP4 files with AC3 though. I have been importing by drag and dropping them onto itunes. If the file has AC3, it just does not show up in my library.

    VLC can't play the resulting MP4 from 607 either. The length being off by 2 hours may be part of this problem.

  6. #6

    Default

    I don't own an Apple TV, but I believe that for these files to play properly they have to actually be copied to the Apple TV itself not streamed from another PC via iTunes. Maybe the v2 is different, I don't know. Everything I read about this was a couple years ago when were first developing the recoding engine for v4 and AC3 in MP4 was still a brand new specification.

    Now VLC not playing the file, or showing the wrong length, is odd. For that we need to rule out corruption in the original stream. Try running the file through Quick Stream Fix and saving it to an H.264 TS file. Then try converting that to an MP4 and see if it works any better.

    Dan
    Dan Haddix
    Developer

  7. #7

    Default

    OK it turns out that the Apple TV v2 does not have any internal storage and requires all media be streamed from an external PC running iTunes. However Pat (phd) found a reference to another forum post which said you might be able to get around iTunes' lack of AC3 support by disabling all the audio processing options in the preference section. However I don't have an Apple TV so I can't verify if this actually works or not. If not then I think you're going to be stuck recoding your audio to AAC.

    Dan
    Dan Haddix
    Developer

  8. #8

    Default

    I don't have any real issues with having to recoding the audio to AAC as long as it stays in sync when I play it back. I mostly want to avoid recoding the video since my experience so far has been it never looks as good as the original.

    The apple TV v2 does have 8gb of flash storage, but you don't have any direct access to it. When streaming movies from itunes, it copies the video as you play it to this storage.

    I tried as you suggested. I opened up my original TS file, I cut off the start and end and then saved back out as a TS file. Then opened up the new TS file with video redo again. This time I saved it out as a H.264 MP4 file. At this point I think that file is corrupt. Windows explorer shows it has having length of over 4 hours when it is only 26 minutes. If I open up the MP4 file with VideoRedo try to play it or save it back out again, I always get the following error:

    Video Thread: H264, error in replenish buffer, details in log file

    I don't know where the log file is at.

    I also tried forcing it to save the audio as AAC, but the behavior is pretty much the same.

  9. #9

    Default

    Sounds like there might be something wrong with the source. Try running it through Quick Stream Fix and saving as a TS, then open that in the main UI, make your edits, and save to MP4.

    Dan
    Dan Haddix
    Developer

  10. #10

    Default

    Running it through the Quick Stream Fix does not help. The resulting TS file from running the Quick Stream Fix plays just fine, but once I try and save it out as a MP4, the file is no longer playable by VideoRedo or by VLC. Can I just send you guys a TS file that is just a couple minutes long? I think that should be enough for you to reproduce the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •