Results 1 to 9 of 9

Thread: Saving from H.264 to MPEG-2 issue

  1. #1

    Default Saving from H.264 to MPEG-2 issue

    My main use for this program is to record and eventually burn sporting events onto BD.

    Using HDHomerun prime, I am recording .WTV files which after editing become MPEG2 files and everything is great.
    Occasionally there is an event that is pre-empted by the prior game. In this case, I will need to "transfer" the missing footage from my DVR via Hauppauge colossus (Which is H.264).

    Now, for sake of speed, I have been taking that little snippet and saving it as MPEG2 (to match the majority of the game) and then join- then burn.
    My issue has been that in the final recording, the segment that was originally H.264 exhibits a tendency to pixelize and have a lot of "mosquito noise".

    Now if I convert the 2nd segment to H.264 to match the first, then everything is OK. But it adds an additional 35-40 minutes to convert the much bigger file over. (a full recode is needed).

    My questions are

    1) I have my colossus set to capture at close to the maximum bit rate - something like 17MBPS - should I dial this back down to something lower?

    2) I know in the menu there is a MPEG2-> H.264 conversion % meter - is there also such a thing for the reverse, or any such setting that I should be looking at?

    Any and all suggestions would be appreciated so I can save 40 minutes each time this situation comes up

    Thank you

  2. #2

    Default

    Does the original colossus capture have the "misquito noise"? Or only after it's been recoded to MPEG-2?

    There is a setting for H.264-MPEG2 quality as well, which I believe defaults to 120%. You may want to try increasing that, or just setting the profile to "force recode and setting the bitrates manually, to see if that improves the quality.
    Dan Haddix
    Developer

  3. #3

    Default

    Quote Originally Posted by Dan203 View Post
    Does the original colossus capture have the "misquito noise"? Or only after it's been recoded to MPEG-2?

    There is a setting for H.264-MPEG2 quality as well, which I believe defaults to 120%. You may want to try increasing that, or just setting the profile to "force recode and setting the bitrates manually, to see if that improves the quality.
    The macro-blocking is ONLY evident after the burn to the disc, it is NOT EVIDENT in Videoredo after the conversion, only after the burn onto the disc

    Would REDUCING the bit rate in the colossus change anything, or should I first try increasing that setting from 120 to say 150?

  4. #4

    Default

    Perhaps the program you're using to create the disc is recoding the video again and that's causing the problem?
    Dan Haddix
    Developer

  5. #5

    Default

    Quote Originally Posted by Dan203 View Post
    Perhaps the program you're using to create the disc is recoding the video again and that's causing the problem?
    I am using MultiAVCHD.
    I have used it since August 2014 when I first started this endeavor. And this issue has only become apparent in the last 6 weeks.

  6. #6

    Default

    Hmmm.... if the output file looks OK when you play it in other software then something must be happening when creating the disc. If it looked bad after you output from VRD then I say we're the problem, but that doesn't seem to be the case. Unless there is some setting that the BD player doesn't like. I don't know enough about the BD spec to say for sure if that's the case. Since you're joing two segments you might want to make sure both segments match exactly using MediaInfo. It's possible there is some incompatibility between the two segments that's causing the issue.
    Dan Haddix
    Developer

  7. #7

    Default

    Quote Originally Posted by Dan203 View Post
    Hmmm.... if the output file looks OK when you play it in other software then something must be happening when creating the disc. If it looked bad after you output from VRD then I say we're the problem, but that doesn't seem to be the case. Unless there is some setting that the BD player doesn't like. I don't know enough about the BD spec to say for sure if that's the case. Since you're joing two segments you might want to make sure both segments match exactly using MediaInfo. It's possible there is some incompatibility between the two segments that's causing the issue.
    The only 'software' I would play it in is VRD - I guess I could try in Windows media center and see if the issue was there as well.

    I will attempt to increase that setting and see if that helps at all.

  8. #8

    Default

    Try VLC and see how it looks there. If the file looks OK in VLC then the BD software must be the issue. If it doesn't then VRD is probably at fault.
    Dan Haddix
    Developer

  9. #9

    Default

    Quote Originally Posted by Dan203 View Post
    Try VLC and see how it looks there. If the file looks OK in VLC then the BD software must be the issue. If it doesn't then VRD is probably at fault.
    I will download VLC and see if that issue is visible there. This thread may be dormant for a while because I will have to take time to manually duplicate the issue as the previous Files have been deleted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •