Create video from Joiner list fails, FFmpeg moov_size error

Celluloid

New member
Greetings All,

I have two PCs (home and work) each with their own VRD TV Suite licensed installs.
The PCs are similar (not identical) running Windows 10 Pro version 2004.
Both are 3.4+ GHz quad core, 16 Gigabytes RAM, SSD Drives with 70+ Gigabytes free.
Both have VRD 6.62.2.823 and 5.4.84.771 installed.

On the home PC using VRD 6, if I load an .mp4 video into the Joiner and add a
couple title templates and then "Create video from joiner list" the process begins
and then completes/crashes after only a couple seconds. An output file of 0 bytes
is created. I'm using the standard "MP4 Intelligent Recode" output profile.

I can repeat this process with the same source files on the home PC using VRD 5 and it works fine.
I can also repeat using the same source files on the work PC with VRD 5 OR 6 and it works fine???
The home PC has had various VRD 6 versions installed but to no avail.

After comparing VRD 6 log files it appears something is wrong with the parameters being passed to FFmpeg:

Successful log excerpt:
2020-09-30 10:15:56 H264 global PTS/DTS adjustment of -33.33, reset to 0
2020-09-30 10:15:56 MP4 muxing, allocating 'moov_size' of 6702992 bytes, Video: 2616016 bytes, Audio: 4086976, Output frames: 108959
2020-09-30 10:15:56 At rebase

Failed log excerpt:
2020-09-30 21:16:35 H264 global PTS/DTS adjustment of -33.33, reset to 0
2020-09-30 21:16:35 MP4 muxing, allocating 'moov_size' of 50374464351464 bytes, Video: 19658327552008 bytes, Audio: 30716136799456, Output frames: 819096981292
2020-09-30 21:16:35 FFmpeg (Error) - Value 50374464351464.000000 for parameter 'moov_size' out of range [0 - 2.14748e+09]
2020-09-30 21:16:35 FFmpeg (Error) - Error setting option moov_size to value 50374464351464.
2020-09-30 21:16:35 Output graph aborted at module: Output muxer, error: FFmpeg muxer: error writing file header.

I've tried disabling antivirus, uninstall and reinstall VRD 6, run VRD 6 as admin, and no difference.

Any help is sincerely appreciated!

Thank-you.
 

Attachments

Dan203

Senior Developer
Staff member
This is not anything you're doing wrong. We changed the way the MOOV atom works in v6.

Can you send us an email to support? We'd like to get a sample of this file so we can figure out what's going wrong. This is only one of a handful of times we've ever see a report of the new method failing so it's rare.
 

PhilR

New member
Was there a resolution found for this issue?

I seem to be having the exact same problem creating a video from the Joiner. (I can save a video after cutting out sections without a problem -- I just get the crashing trying to Create Video from joiner list as described above.)

The corresponding entry from my log file is:

2020-12-19 12:22:41 H264 global PTS/DTS adjustment of -100.10, reset to 0
2020-12-19 12:22:41 MP4 muxing, allocating 'moov_size' of 39453037730120 bytes, Video: 15386925135664 bytes, Audio: 24066112594456, Output frames: 641121880611
2020-12-19 12:22:41 FFmpeg (Error) - Value 39453037730120.000000 for parameter 'moov_size' out of range [0 - 2.14748e+09]
2020-12-19 12:22:41 FFmpeg (Error) - Error setting option moov_size to value 39453037730120.
2020-12-19 12:22:41 Output graph aborted at module: Output muxer, error: FFmpeg muxer: error writing file header.

I am using Version 6.62.2.826 - Nov 19 2020

In my case, the only change I am making in the Joiner is to add a title.
The original video was an MP4 created using an Elgato video capture of a VHS-C video.
I then trimmed it in VideoRedo (cut some frames from start and end) and saved that file.
Then opened that trimmed file created by VideoRedo and added it to the joiner.

Here is the info from MediaInfo utility on the trimmed MP4 file
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 550 MiB
Duration : 30 min 49 s
Overall bit rate : 2 495 kb/s
Writing application : VideoReDo (Lavf58.29.100)


Thanks!
Phil
 

Celluloid

New member
Was there a resolution found for this issue?

I seem to be having the exact same problem creating a video from the Joiner. (I can save a video after cutting out sections without a problem -- I just get the crashing trying to Create Video from joiner list as described above.)
Hi Phil,
I'm not aware of a resolution but I can suggest a work around. The problem seems to have something to do with moving the "MOOV ATOM" to the beginning of the video file. This is usually important if the video is going to be streamed but may not matter for other types of playback.

Open the MP4 output profile:
Tools > Manage Output Profiles > MP4 > Show Advanced
Make the following change:
3189

This allows me to successfully edit and save an MP4 from VideoReDo Joiner.
I do ultimately need the MOOV ATOM at the beginning of the file and use FFMPEG to do so after editing.
 
Top Bottom