getting no AC3-sound from the wtv ?

Dirk67

New member
I bought V4 some days ago,

now I found out that within VRD the AC3- sound is not processed (not accessible) from the wtv files..
only the MPA(MPEG Audio) -sound is there (and is in the output file)

(regarding wtv files from Win7-Mediacenter recording german DVB-S (live-TV) --> some stations here broadcast AC3-sound with some movies.. --> talking about just SD (MPEG2) not HD (H.264) recordings)

Is this a known issue ?
(Is it planned to be realized in some future version ?)
 
Last edited:

dlflannery

Moderator
I bought V4 some days ago,

now I found out that within VRD the AC3- sound is not processed (not accessible) from the wtv files..
only the MPA(MPEG Audio) -sound is there (and is in the output file)

(regarding wtv files from Win7-Mediacenter recording german DVB-S (live-TV) --> some stations here broadcast AC3-sound with some movies.. --> talking about just SD (MPEG2) not HD (H.264) recordings)

Is this a known issue ?
(Is it planned to be realized in some future version ?)
AC3 output is not officially supported yet but there is a special profile that you can import and modify that will pass AC3 from input file to output file. The profile is an attachment to **this post**. Profiles are XML format. If you look in the special profile you will see this in the AudioAttributes section:
<Encoder allowAC3="y">Auto</Encoder>
The 'allowAC3="y" ' attribute enables the AC3 pass through.

I don't know if this works for wtv inputs (wtv support is under development) and if you have more than one audio track in the input file, you may have to select the AC3 track.
 

Dirk67

New member
hmmm...
I'm not shure if I understand you right ?

as you can see in my previous post I have as input a mpeg2 file with AC3 (in a wtv-"container")
and need as output (after cutting) again a mpeg2 file with AC3 (as mpg-file)
("smart edit"/no recoding if possible)

I thought this should work since it is written here as supported output format:
"MPEG2, program, transport and dvr-ms streams with MPEG and AC-3 audio"
and
"AC3 and AAC-HE audio is supported if they are present in the source file"

maybe this statements are somehow misleading to someone who wants to buy this program like me (?)
(to be honest: I am not so familiar with all those container-formats an codecs and their combinations)


so you think I can create a output-profile for mpeg2 output and insert the line
<Encoder allowAC3="y">Auto</Encoder>
like it is found in the h.264-output-profile you mentioned ?

and if you have more than one audio track in the input file, you may have to select the AC3 track.
how can I do that ?
 

Danr

Administrator
Staff member
I bought V4 some days ago,

now I found out that within VRD the AC3- sound is not processed (not accessible) from the wtv files..
only the MPA(MPEG Audio) -sound is there (and is in the output file)

(regarding wtv files from Win7-Mediacenter recording german DVB-S (live-TV) --> some stations here broadcast AC3-sound with some movies.. --> talking about just SD (MPEG2) not HD (H.264) recordings)

Is this a known issue ?
(Is it planned to be realized in some future version ?)
Yes, this is a known issue. We have one example from the BBC in the UK which opens up with AC3 here, but plays MPEG2 on the user's system. Would be good to have an example from another country which has similar problems.

Can you upload an short (50-200MB) sample to our FTP?

http://www.videoredo.net/msgBoard/showthread.php?t=15807
Please don't forget to send the email.


Any chance you can record a short WTV file
 

Dirk67

New member
again as an explanation of what I mean:
______________________________________________
if you open the original mtv,
then you can see under "tools" -> "select stream" both audio streams:
"AC3-Audio" AND "MPEG1-Audio"
this is the right way (this is how it was broadcasted by the german "Pro7" Station)



also with "tools" -> "QuickStream Fix" -> "Select Stream"
it shows up the same (right) way...

but when you apply the "QuickStream Fix" the resulting mpg-file has lost the "AC3-Audio"
--> see followig Picture


also when you cut the wtv and save it then as mpg or dvd the AC3-Audio is "lost"...

This is the error that I meant.
(not shure if this was clear before ?)


maybe only the question of right profiles ?
but if I select it explicit in the "Select Stream" dialog,
I would expect the AC3 to be preserved by the software (?)
 

Attachments

Danr

Administrator
Staff member
Thanks for the explanation, and we are aware of that exact behavior. Good news is that I think we just found a solution so the stream selection will now work!

Looking forward to checking it out on your file. One of the other German files, with MPEG and AC3 audio now works as expected.
 
Top Bottom