Issues running VAP on schedule


New member
I've been using VAP for about a year and found it to be very useful when it works, but I've run into some issues. I've tried installing and running it as a schedule on two separate computers, and both present different errors when the scheduled task has to wake the computer to run.

Computer 1's issue:

Almost every day, a error message would be on the screen when I returned to my computer. The message says to run VRD one time as administrator to correct the issue. I've done this often, but it never resolves the issue. If I launch VAP manually without running VRD as administrator, it opens and runs just fine.​


Computer 2 is my HTPC that doesn't reliably stay in sleep mode. Because of this, I think I see errors less often, but there are two recurring problems when using VAP as a scheduled task on this computer:

1. The output folder is a mapped network drive assigned to drive letter T. Occasionally, I will return to the computer and see an error from VAP stating that the output path (T:\) is missing. I've checked on more than one occasion and every time, Windows has been connected to drive T:\ with no issues. If I close and reopen VAP at that point, it finds all the location paths just fine.

2. The files should be converting to WTV(h.264). Sometimes VAP loses track of the output file format selected and converts the files to .mpeg instead. When it does this, the files lose all of the program details for the processed files. When I first encountered this issue, I thought the recordings were missing, but then I discovered that they were just not showing up in WMC because they were no longer .wtv files.

I can use VRD to convert them back to .wtv, but then I'm missing all the information about the recording. The only thing I have to go on at that point is the original file name that includes the show name, channel callsign, and date/time of the recording.​

Like I said before, it appears that these issues are all related to the computers being asleep at the time the VAP task is scheduled to run. Outside of turning off sleep mode altogether, is there something I can do to correct these issues? For the times that I've been home and using the computers at the scheduled task times, everything seems to behave as expected.
Last edited:


Running VAP as a scheduled task has always been a troublesome issue. I don't have any advice to offer other than a careful reading of the sticky thread on that topic:
Have you tried the run-when-user-logged-in thing described at the bottom of the first post?

The message about running VRD once as administrator really just means VAP could not make contact with the VRD COM functions. The only known cause of this was the need to run VRD once as administrator but obviously in the task scheduler scenario there must be other (unknown to me) causes.

The sticky thread was done in the context of Win7, which I'm still running. Things may be different for Win10.

If encoding to the wrong encoding happens other than for scheduled runs, and you can describe the use case in sufficient detail for me to duplicate it, I will be very interested in debugging it. Otherwise I tend to lump it into the just-another-task-scheduler-related-glitch category.


New member
I found schedule a bat which then calls your VAP better but bat file needs;
cd "C:\Program Files (x86)\VAP"
start "" "VideoReDoAutoprocessor.exe" -hotstart -shutdown:5

Starting from the VAP folder worked for me as gleaned from this thread;
Top Bottom