No PID specified when trying to open a Transport stream

I have a Panasonic video recorder which stores the videos in MTS files. I have just bought Videoredo TVSuite V6 to enable me to Grab a batch of files (shots) and join them together in a simple way in order to output the resultant video as an MP4 file without using an editing suite. The files are recorded in HG1920 quality. When I use the joiner system in VideoRedo to try to join the files together, I get the message "No PID specified when trying to open a Transport stream" do I have a setting in VideoRedo which I need to change or have I got a codec which is missing? If I pick up one MTS file on its own, then Videoredo will play it, but I want to take a bunch of MTS files and combine / join them together.
Can you point me in the right direction regarding this please.
 

Dan203

Senior Developer
Staff member
Two things you can try....

Firs go to Tools->Options->MBytes to scan at file open and try doubling the value. If that doesn't work try checking the "Ignore TS maps" option on the same page. If that still doesn't open then open the file in MediaInfo and post the info here so I can see if there is something in the file which might cause an issu.
 

jmc

Active member
I was just dealing with that (.TS files). Batch process processed several then did not like #5.
"Ignore TS Maps" worked. change the setting back when you are done.
 
Top Bottom