Suite 4 MAK fails after Win 10 upgrade


VideoReDo TVSuite4 674
VideoReDo TVSuite3 616
TiVo Desktop 2.7

After upgrading to Win10, and sorting out several issues and settings, I found Suite 4 no longer see's my MAK and gives the errors.
Suite3 still works.
I tried re-entering the MAK in TiVo Desktop but no joy.
Tried reinstalling TiVo Desktop....same results.....
Any Ideas?

Thanks Much,


Ex-Senior Developer
Can you play the files in Windows Media Player? Probably not. A LOT of people on the TiVo forum said they had to reinstall TiVo Desktop after the upgrade to Windows 10 to get it to work again. VideoReDo uses one of the DLls from TiVo Desktop to decrypt .tivo files, so if it doesn't work then VRD wont work either.


No; Won't run there.

I did try to reinstall TiVo Desktop 2.7 over the same version and no difference was detected.
I tied to uninstall TiVo Desktop 2.7 and it complained about "files in use" "TiVo Transfer Service (Process ID 9748)"
Stopped the servisce and it finished. reboot and ran the 'tivo cleaner', reinstalled Desktop joy.
Should it run on 2.7? I found a 2.8, but I was a bit leary about the source.

Still runs in Suite 3 but not in Media Player or Suite 4.

Any Ideas?



Thanks all;

Noticed a warning about not using an "Elevated Privilege" when installing, so I backed-out and double clicked the .exe; That was odd....

After the reinstall procedure, I couldn't get TiVo Desktop to start.
Fiddled with the compatibility settings (ended up turning it off and unchecking 'administrator') ....Desktop started; already had my MAK installed.
So far, all versions I have of VideoReDo & Media Player, Desktop work as they should; still need to try KMTTG and verify results, but the progress I'm seeing says all will be fine.

And Dan;
If you recall my email issue about my button size issue between S3 & S4 versions. It seems to have cleared-up. Not sure if it was the Windows 10 upgrade, or the fact that it forced me to drop down to 1280 x 720 then scale everything back to look ok. Intel's HD 4600 Graphic Control Panel seems to balk at scaling 1920 x 1080; the overscan was really bad.

Thanks Again Guys :)

Last edited:
Top Bottom