TiVo error message #86 when pulling episode


New member
Problem summary: I had problems pulling one episode out of the 81 episodes I was pulling onto my TiVo box. After processing the file in VideoReDo the problem episode looks great in VideoReDo. However when I try and pull it onto my TiVo box I get the TiVo box error message number 86. I am hoping to purchase VideoReDo to solve this problem and problems like this in the future. I am using a trial version.

If you haven’t watched Penguins of Madagascar episodes you are missing out on important life lessons. This is an excellent show. Anyway, I could not transfer (pull) the “All King, No Kingdom” episode of Penguins of Madagascar from my Windows 10 Lenovo Ideapad 110 to my TiVo box. I received the following TiVo box error message:
There was an error. Your request could not be processed. Please try again. (Message number 86). In bottom right hand corner in very small print: BUSY.

I was able to pull the other 80 episodes I was transferring to the TiVo box with no problems. I am using pyTiVo. I pushed all 81 episodes from my TiVo box to an external hard disk drive using TiVo Desktop Plus several years ago to make room for more shows on the TiVo box. Initially the hard drive was connected to my Vista Toshiba Latitude laptop. I could view the problem episode on TiVo desktop with no problems. When I connected the external hard drive to the windows 10 laptop I found that I could not play this episode on TiVo desktop on the windows 10 laptop. There is something different about this episode compared to all the other ones and yet this episode was handled the same way as the other 80 episodes in past years. I installed VideoReDo onto my windows 10 laptop. VideoReDo could not read the file. Then I Installed VideoReDo on my vista laptop and VideoReDo could read the file on that laptop. I then created a copy of the file using VideoReDo (“Save Video” button) on the Vista laptop. VideoReDo was processing the file so I could see it was not a simple copy operation. I then copied that file to my windows 10 laptop. VideoReDo could read that file on my windows 10 laptop. This was excellent. I figured the problem must have been solved. However, I found that I still could not pull this episode onto my TiVo box. I still get error message #86. I tried deleting the pre-episode and post episode frames using VideoReDo thinking that might help. I tried copying the file as a .tivo file in a Roamio TiVo file format since that is the box I have. Still no luck. I still cannot pull this episode onto my TiVo box. I still get the message #86 error message.

Note I only get audio on the windows 10 laptop when I play on TiVo desktop or double click on the file in file explorer, but that is enough to tell me if the episode is playable or not. I can view the video as well as listen to the audio using VideoReDo.



Senior Developer
Staff member
OK first off only a computer with TiVo Desktop or pyTiVo Desktop installed will be able to open the file. They install a special DirectShow filter on the system that VideoReDo needs to be able to decrypt the .tivo file. So first thing to do is to make sure you have either TiVo Desktop or pyTivo Desktop installed on the system.

Next rather than opening the file and saving, run the file through QuickStream Fix. This processes the file a bit differently and can correct some errors in the file that saving may not.

After that if you want to cut out the commercials then open the fixed file, edit and resave.

Now try transferring the final edit to the TiVo.

If that still doesn't work then there may be a corruption in the .tivo header that's causing the problem. The easiest way to fix this is to save the file to a standard .mpg file instead of .tivo, then use the program metagenerator 3 to find the data for the file and apply it to the .mpg. This will create a text file matched to your standard .mpg that pyTivo can read and recreate the metadata when transferring back to the TiVo. This eliminates any potential issues with the header because the header is stripped and the metadata is recreated by metagenerator and pyTivo.

If that still doesn't work then I'm stumped. You don't mention what version of VideoReDo you're using but if you're using any version of TVSuite you can force a recode on the video and see if that fixes the issue. Just make sure to disable the deinterlacer and match all the recode settings to the source file. (newer versions of TVSuite have "same as source" settings for most options, but older versions did not) Completely recoding the video should remove any corruption that might be causing an issue with the TiVo and you're unlikely to notice any quality difference as long as you carefully match all the settings.


New member
Dan, your suggestion of running the corrupted file through QuickStream Fix of VideoReDo TVSuite V5 worked perfectly. I was able to cut commercials before and after the TV episode and then I was able to pull the file onto my TiVo box. Your software is excellent and your support is excellent. I purchased VideoReDo TVSuite V5 on 8/18/19 and have been very happy with it. Thank you very much for all of your help.
Top Bottom