Toppy 6000 PVR Subtitles missing

Barlowdog

New member
I have just been using VideoRedo TV Suite V4 build 4.20.7.629 to edit files from a Topfield 6000 PVR ES.
This receiver is DVB-S compliant and records .rec files and subtitles are recorded in the transport stream.
The VideoRedo files playback ok on the Toppy but the subtitles are "not present".
If I play the files with VLC Media Player the subtitles can be turned on and work ok so they must be present in the VideoRedo files.
There is no option for the 6000 in VideoRedo so I tried both the 5000 and 5800 options but both give the same result.
I am impressed with VideoRedo and intended to purchase a copy but it is no good for me if I can't get the subtitles on the Toppy to work.
Has anyone got experience of this or any ideas to correct it.
Thanks
 

iron

New member
I have a 5800 and have seen this effect. As you have discovered the subtitle info is still in the edited file and reason why the PVR does not recognise it is a mistake in the file's Topfield specific header.

When VideoRedo edits and resaves a transport stream it changes the value of a parameter called the 'service id' to 1. That really shouldn't matter but the Topfield transport stream has a copy of the service id value in it's header and won't recognise subtitles unless the header and actual values match.

To reenable subtitles in the edited file the two bytes in the header at decimal offsets 18 and 19 should be changed to 0 and 1 respectively.
 
Top Bottom