Using Videoredo in Parallels Desktop 16.5 on M1 Macbook Air


New member
Or should I say "Not Yet Using Videoredo" on my m1?

I am running the Windows 10 Arm Preview build.

I installed VRDTVS-6-60-4-806a first. It went through the set-up and installation routine, but the program would not start. I uninstalled it and then installed VRDTVS-6-62-4-827 with the same result. It goes through the install configuration routine, but won't open.

If I can't get it to work, it's no big deal because I have always used Videoredo exclusively on my home theatre NUC PCs running Windows 10 professional, and it has never let me down after years of use, and as irreplaceable.

Has anyone else tried installation with Parallels and gotten Videoreo to work?


Ex-Senior Developer
I got it to work on mine. I had to go to the exe, right click, pick compatibility, then emulation settings and change the first dropdown to "strict execution".


New member
I’m using Parallels (Windows 10) on a 2017 Macbook Air base variant (8B RAM, 128GB SSD, i5 5350u) at the time of writing this reply. So, I’ll share my experience with you.

It runs smoothly and doesn’t really stutter. I use it largely for firing up Power BI with both Windows and Mac-based Excel versions. So, the workload gets heavy from time to time but the machine pulls the load nicely.

However, that doesn’t mean that performance is buttery smooth and everything is roses and sunshine. When I’m running Parallels with Power BI and both Excels (windows and Mac), the MBA gets noticeably slow, but just short of stuttering.

For instance, I can’t launch more than 8–10 tabs in Safari otherwise it starts to lag. Not to mention, it’s able to run Power BI but the performance is slow. It can sometimes take 10+ seconds to run a basic query which otherwise takes 2–3 seconds on dedicated Windows machines. I’ve noticed a similar thing with Excel.
ppsspp emulator
Last edited:
Top Bottom