VideoReDo TVSuite V6 beta: v6.62.4.830a dials home

BazzaG

New member
While I intend to revert back to a older version of VRD (see: Need a downgrade to previous beta).

I have an issue with VideoReDo TVSuite V6 beta: v6.62.4.830a, namely ... EVERY time I save a edited video file VRD dials home ... which I have blocked in my Firewall.

Here's an entry from my FW log:

VideoRedo was blocked from connecting to the Internet (151.139.128.14:HTTP)

Why is VRD dialing home every time I save an edited video file?
What data is VRD trying to send?
Is there an option in VRD that stops this behaviour? If so, what/where?

Cheers...
 

Danr

Administrator
Staff member
There's no code in VRD to phone home on each save. We only phone home for version checks as set by the user on the Tools>Options>Startup page. BTW, the URL we contact with is videoredo.com [144.202.14.219]. If a different IP is being contacted, then it's not us.

How did you detect this?
 
Last edited:

BazzaG

New member
My firewall issues an alert saying that VRD was trying to access the internet using the IP address as shown above whenever I hit SAVE button.

151.139.128.14 is owned by Highwinds Network Group in the US.

The VRD installer was D/L'd from here: https://videoredo.net/beta/VRDTVS-6-62-4-830a.exe

I don't recall this occurring the previous version of VRD of I was using: v6.62.4.827b.
 

Danr

Administrator
Staff member
I think that IP, 151.139.128.14, belongs to StackPath which looks to be a company that does application monitoring and metrics. Anyway, it's not something that's embedded in our code. What firewall are you using, we can try duplicating it here?

Try installing another version of VideoReDo, an older version or a later version (see below) and see if the situation persists. Again, not sure what we can do about since it doesn't appear to be originating in our code.

For an earlier version try the 827 release: https://www.videoredo.com/en/Download.htm?download=tvsuitev6

For a later version here https://www.dropbox.com/s/hi8y2uaxggagjcr/VRDTVS-6-62-4-830h.exe?dl=0 (as yet unreleased beta, but more stable than 830a).
 

BazzaG

New member
Yep, Highwinds Network Group is owned by StackPath. I haven't looked them up beyond looking at who owned the IP address.

I'm using ZoneAlarm Pro.

I've run multiple AV and AS scans and they all come up clean.

In Post #3 of this thread:

https://videoredo.net/msgBoard/index.php?threads/need-a-downgrade-to-previous-beta.37655/

I asked the question about downgrading VRD. Since I haven't done so before I just want to make sure that I don't stuff VRD up missing a step or whatever.

Since it's almost midnight local time, so that's all for now, need to get some shuteye.
 

Danr

Administrator
Staff member
Don't specifically downgrade, install each version into it's own folder, they can all exist on the system at the same time and share settings and profiles. There will be only one shortcut on the desktop/start menu, which you can manually edit if you like. Or setup your own desktop shortcuts to each version.

Keep us posted. I know there's nothing we've coded into VideoReDo that phones home, just want to be sure that a 3rd party library or malware didn't sneak into our builds. Personally, my guess is that there's another application on your system that has installed a system wide hook and it triggering the phone home.
 

BazzaG

New member
While I accept that there are times when its useful to be able to install multiple versions of software, that's not really the way I want to do this normally.

I have a bunch of questions about doing this but they are beyond the scope of this thread.

Perhaps this is one of those times when it would be useful for testing purposes.

With regards to sharing settings & profiles, there are 2 things that happened after I started 830a the 1st time:

1. It had to re-register, and
2. It reverted several settings back to their default values. One example, was the automatic software update check on startup.

I don't recall either of those happening in the past.

Lastly, I've only been using VRD since Dec 2020 and I've only done 4 updates since then including 830a. The 1st 3 were all done back in December when I reported a problem in v6.61.3.821a which was fixed in v6.62.2.286a & I then updated to the current GA release: v6.62.4.827b.

Another note, is that all of the problems I've experienced with VRD have all been with video files that have MPEG-2 as the video codec.....

Anyway, time to get back on topic ... I've taken a full backup of my PC and I'll install 827b and do some comparison testing.
 

BazzaG

New member
OK, I UNinstalled 830a and re-installed 827b.

Updated ZAP to ASK for internet access by several VRD pgms listed (auto added). Also, ran some network monitoring pgms.

VRD 827b did *NOT* try to "dial home" or anywhere else for that matter when saving several edited videos.

I will look at installing a later version of VRD when I get a chance, except it WONT be 830a.

BFN...
 

Dan203

Senior Developer
Staff member
Any chance you'd be willing to install 830a in a separate directory just to see if it does sill try to "dial home"? That would let us know if something snuck into our code somehow.
 

BazzaG

New member
I've sent some VRD logs, etc. for the crash/abend when VRD processes a video file with MPEG-2 codec and multiple audio tracks to your support email addy.

Now, as to installing 830a again ... I will try to find the time to do so.
 

Danr

Administrator
Staff member
Try installing this version, which has some bug fixes, into a separate folder. It won't affect your 827b installation at all.


FYI, I installed 830a and ZoneAlarm in a VM, no error or warning messages when saving.

1) What input and output file formats are you using?
2) What settings should I setup in ZoneAlarm to try and duplicate your ZA environment?
 

BazzaG

New member
I think I have most settings set to their default values and some listed below may actually be their default values...

Application Control -> Settings:

* Network Firewall screens all programs set to Max
* Your DefenseNet is set to Automatic (which I think is the default)

Application -> Advanced Settings -> Alerts & Functionality:

* Show alert when Internet access is denied - Enabled

On the Tools menu -> Logs ->

** Main:

* Alert Events Shown: Medium
* Event Logging: On
* Program Logging: High

** Alert Event:

OSFirewall both Alert & Log enabled

-----

As to me retesting 830a ... haven't had the chance, maybe tomorrow my time.
 

DrP

Member
FWIW, I kicked Wireshark off and noticed no activity that could be associated with saving a file from VideoRedo 830a. VR is running under Windows 7, itself in a VM hosted on linux. Wireshark sees all the traffic in and out of the VM.
 

BazzaG

New member
Hi,

Today I UNinstalled ZAP, ran the ZA Clean pgm & then re-installed ZAP, re-configured & tested. As far as I can tell ZAP is working correctly.

I then tested VRD_v827 and received NO request to access my network upon saving a edited video file, neither local or remote. Since I run ZAP PGM control at MAX. level VRD_v827 did ask for permission to access/open a video file.

Here's screenshots of the ZAP PGM rules for VRD:

3259

3260

Once done, I took full bkup of my PC, which I will restore once I've re-tested VRD_830a.

I then installed VRD_v830a to a different directory and tested.

Approx. 30 secs after opening/starting VRD_v830a I received a network access request for MS pgm: Video.UI.exe:

3261

I denied access. This is probably coincidental. I did NOT receive the same request while VRD_827 was running.

This pgm looks legit, as I previously several different AV scans have all returned "clean".

Here's the ZAP PGM rules after installing/starting VRD_830a. At this stage I have NOT tried to open, edit & save a video file:

3262

3264

3263

Here are sum checksums, etc. for the 830a installer:

Name: VRDTVS-6-62-4-830a.exe
Type: .exe
Size: 57.5 MB
Bytes: 60382208
Modified: 2021-04-29 14:38:34
Attributes: A
Copies: 1
CRC32: B1375102
CRC64: 911E5F979F277E23
MD5: 192CB435772F794826829E9D91E3E8CC
RIPEMD160: 37FCD07B49335D02E8D13FB2B860515CC2F20978
SHA1: 77EA049308ADE6C8A52B93707ACCAFB71D85CEF1
BLAKE2S: 4F3624D05AC48C5817180FEB865934918BFBF061B5211B257992D09E8FEB4CEF
SHA256: 8FC43CAFF1C3E810DD5842D4F30EDFACE626B3207BF7228D49355315B065A1A8
SHA3_256: FD777CEDC60A6D017DF73232B224A19F5239251FE4FCA94D5ED7DDF57FA4A57C

Ok, now I open, edited and saved a video file using VRD_830a and I did *NOT* get any network access alerts.

No idea why not, perhaps ZAP wasn't working correctly but if that was the case, then it was affecting VRD ONLY.

OK, time to restore my PC and for this thread to be closed ......
 

Danr

Administrator
Staff member
Looks like the problem is with Video.UI.exe not VideoReDo. Just glad to know it's not something that snuck into our code base by a back door.
 

BazzaG

New member
No it wasn't. The ZAP log clearly showed that it was blocking VRD. As to why, is a question that I can not answer.
 
Top Bottom