VideRedo Pro version 5 not Working after installing Beta version 6


New member
I installed the beta pro version 6 yesterday.

After trying out the beta version, I tried to use my old pro version 5 installation and was greeted by a message saying that several installation files are missing or damaged !.
It appears that Beta-Pro version 6 installed to the same directory as my Pro version 5, overwriting the associated files !.
In the process the v5 license has been replaced (or modified) by the temporary v6 one I assume.

Removing V6 and re-installing v5 left me with the license screen message (see attached).

Being desperate at this point (I needed an editor) I purchased the tvsuit version 6 (as the pro version is not availlable).

I removed everything and installed this TV version 6, which worked well enough to get some quick edits done.

After completing my urgent tasks I went back and tried to install VRD Pro vers 5 again.

The program thiis time installed, and activated online, but then came up with the registration screen again !!!.

I then viewed the license info (see attached).

This says the VRD pro license expired on 03/06/2019 !!!!.

Which can't be the case because I've been using it untill Thursday !!!.

What's the trick ?.

Can anyone help sort out this fiasco ?.

There must be some way of re-installing my original licensed VRD5 pro .


Last edited:


I too am just about to crack it with my VRD Pro 6 as well, i don't use it a lot at the moment, but i just tried to reconvert one of my GoPro files, only to find the previous license key had expired, yet again, so i found the November key and applied that, but VRD failed to activate, then i read the foot notes where i have to insert my original VRD Pro 5 key and activate that, then open VRD again and enter the new November key.

VRD now works, but now i am still having issues with converting 4k/60p HEVC GoPro files to 4k/60p AVC, telling me there is a LargeBufferMalloc, no more memory

Looks like i am going to have to try Handbrake or some other free Open Source software just to do my conversions from h265 to h264 and then bring those into VRD Pro 6 for editing.

It is very frustrating.


New member
My problem with vrd 5 pro license de-activating, was solved by e-mail support from Dan.

I won't try to explain the procedure, it involved entering long codes generated by VRD's license code generator.
Anyway thanks to DAN and his help, my VRD 5 pro is working again.

I won't be trying VRDPro-6-91-6-808a again, I will wait for the next version to be released.

Don't ever want a repeat of that nightmare experience !


The procedure is quite easy if you happen to apply the original Pro 5 key first, then activate again using the latest November key, but we should not have to go thru this silly process every time a new release version is issued, the same Pro 6 key should remain activated each time we install a new updated version, because this is the way it was back in the old version 5 days, never had to apply new keys almost every single month like now.

This issue with the LargeBufferMalloc, no more memory error needs to be resolved as well, it has been an ongoing issue from time to time for years, pops its nasty head up every now and then, and i am sick of it, now i get this error simply trying to convert a 4k/60p HEVC (MP4) to 4k/60p AVC (MP4) and it should be working, but it doesn't.
Top Bottom