Where to set x264 as the default encoder

MrVideo

Active member
When re-encoding, the default encoder selection is "default." But, I have no clue as to where to set the default. I've look through all of the Tools->Options, including the manual ones.
 

Danr

Administrator
Staff member
Tools>Options>Stream parameters, Default Encoder. Select "software"
 

MrVideo

Active member
I looked right at that but missed it. But, that is already the default and doesn't solve the issue. The software encoder is not selecting x264 by default. When I recoded the H.264/4:2:2 video and left it at default, the result was H.264/4:2:2. It wasn't until I forced it to x264 that the result was H.264/4:2:0. I'm guessing that x264 can't be set as the default software encoder and that I will have to create my own profile with the recoding parameters that I want.
 

MrVideo

Active member
The link points to my audio meter question. The x264 can now do 4:2:2 encoding? I looked for a 4:2:0 setting when doing the recoding, but couldn't find it. If x264 is the default software encoder, why is there both a x264 and software encoder selection in the Encoder pulldown list? When I select Software, the chroma is 4:2:2. When I select x264, the chroma is 4:2:0.

See my confusion?
 

MrVideo

Active member
I'm even more confused: www.videoredopro.com/VRDPro_Application_Notes/op_settings---video-tab.html

It has the following:

"Note, not all output codecs support 4:2:2 encoding. Specifically the Intel Quick Sync encoder, and default software codecs only support 4:2:0 chroma. If you have issues setting this value set the Output codec set to either ffMpeg for MPEG2, x264 or the MC Pro codecs."

But, as noted above, when software is selected, the chroma stays at 4:2:2. Only when I change to x264,do I get 4:2:0. There is no chroma selection in the Edit Output Profile GUI.
 

Dan203

Senior Developer
Staff member
Are you using v6 or v5? In v5 we still have the MainConcept encoder, that's why both are listed. In v6 x264 is the default for "software" and the old MainConcept encoder is listed as "classic".

The chroma will match the source if possible. But if you want to force a specific chroma you can change it on the Video tab in the profile. (near the bottom, labeled "Video Chroma")
 

MrVideo

Active member
VRDPro V6. In the Edit Output Profile there are no tabs. In the video section of the GUI, there is no Chroma option. In the Advance section, under video encoding options, there is no Chroma option.
 

Dan203

Senior Developer
Staff member
VRDPro V6. In the Edit Output Profile there are no tabs. In the video section of the GUI, there is no Chroma option. In the Advance section, under video encoding options, there is no Chroma option.
Oh are you using the consumer dialog to edit profiles? That's more limited that the Pro grid dialog. If you want to use the full power of Pro you need to use the grid dialog.
 

MrVideo

Active member
Found it. There is a VRDPro setting (#1) to use grid mode. This instruction needs to be added to the Application Notes web page.
 

Dan203

Senior Developer
Staff member
Found it. There is a VRDPro setting (#1) to use grid mode. This instruction needs to be added to the Application Notes web page.
That should be set by default. Did you change it yourself?

Edit: Never mind I see it's set to off by default. That's a bug. We'll fix in next release.
 

MrVideo

Active member
That will only affect new installs? I'm assuming that current users will not have it change to true if they set it to false.
 

Dan203

Senior Developer
Staff member
Yeah. Just need to change the default that's used when the option isn’t set. In your case the option is now set so it'll stick.
 
Top Bottom