Results 1 to 7 of 7

Thread: Trimming Matroska Files Not Working Properly

  1. #1
    Join Date
    Aug 2018
    Location
    United States
    Posts
    1

    Exclamation Trimming Matroska Files Not Working Properly

    Hello, everyone.

    When I use the trim function to simply trim a matroska video without re-encoding anything, I get proper sized files but there are no video or audio streams in the files. Anyone else have this issue with this container or any others when trimming? If so, do any of you know what could be done to correct this issue?

    Thank You
    Video Editing System
    AMD Ryzen 7 1700 CPU
    16GB Kingston DDR4-RAM

    DJ + Audio Production System
    Intel i7-6700 CPU
    32GB G.SKILL DDR3-RAM

    VideoReDo TV Suite v5.3.83.763

  2. #2

    Default

    I'm using VRD Pro but yes, there is a problem.

    When trim&copy on a MKV file...

    H.264.mkv
    mpg.mkv

    The file output, when placed back into VRD pops up a message about elementary streams and do I want to
    open it in the Elementary Stream muxer. When I say yes and then save the file again
    I get a functional good video file with NO audio...of course, as the Muxer shows no audio when muxing.

    ----------------
    VLC won't play the "Original" trim&copy bit.(NOT MUXED)
    MPClassic plays very broken video with no audio.
    Last edited by jmc; August 6th, 2018 at 11:05 AM.

  3. #3
    Join Date
    Feb 2004
    Posts
    12,150
    Blog Entries
    7

    Default

    Grab the latest build from here and see if that resolves the problem:

    http://www.videoredo.com/Installs/VR...90-90-770a.exe
    Dan Rosen ( VideoReDo )

  4. #4

    Default

    Quote Originally Posted by DanR View Post
    Grab the latest build from here and see if that resolves the problem:

    http://www.videoredo.com/Installs/VR...90-90-770a.exe

    Ok, redid the Trim&Copy MPG.MKV test.
    I had Trim&Copy trim using the "section markers" setting.

    VRD says elementary stream with the (unplayable) Trim&Copy segment and MUXING makes it a playable file with no audio.

    MUXing mpg.mkv to mpg.mkv... now plays but bad quality video. (video jumpy,blocky,jerky,green flashes)

    MUXing mpg.mkv to H264.mkv... Quality MUCH MUCH better...smooth, not perfect tho, a "block" here,there.

    Forgot to mention, the MUX always crashes but leaves behind the "now playable" video file with no audio.


    VRDPro-5-90-90-770a,
    W7/64, Intel 6core 3930

    Thanks,
    jmc
    Last edited by jmc; August 7th, 2018 at 10:00 AM.

  5. #5
    Join Date
    Feb 2004
    Posts
    12,150
    Blog Entries
    7

    Default

    Sorry, misread your original message. You shouldn't use trim and copy on MKV files, or MP4/MOV files either. Trim and copy really primarily useful for program stream and transport stream files.
    Dan Rosen ( VideoReDo )

  6. #6

    Default

    Quote Originally Posted by DanR View Post
    Sorry, misread your original message. You shouldn't use trim and copy on MKV files, or MP4/MOV files either. Trim and copy really primarily useful for program stream and transport stream files.
    Ok, good to know.

    Trim&Copy does give a warning for .MP4 files but nothing for MKV files.

    Thanks,
    jmc

  7. #7

    Default

    Yeah most files have a header so if you trim them they are no longer valid. TS and PS have a repeating header in the stream, so they can be trimmed like this without issue. TiVo files only work because after the header they're just standard PS or TS so we copy the header first, then trim the remaining part of the file. That doesn't work with other files as the headers contain byte offsets to frames, streams, etc...
    Dan Haddix
    Developer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •