Results 1 to 2 of 2

Thread: video ring buffer overflow

  1. #1
    Join Date
    Mar 2005
    Location
    Australia
    Posts
    142

    Default video ring buffer overflow

    I'm using VRDTVS 5.3.83.770

    I get the video ring buffer overflow message.

    I've gone to the Tools>Options>Stream Parameters page, make sure the "Double Video Buffer Memory" is checked but it's not there.

    Multiple audio streams has been unchecked.

  2. #2

    Default

    Quote Originally Posted by KISSMAD View Post
    I'm using VRDTVS 5.3.83.770

    I get the video ring buffer overflow message.
    I've gone to the Tools>Options>Stream Parameters page, make sure the "Double Video Buffer Memory" is checked but it's not there.
    Multiple audio streams has been unchecked.
    Here is some stuff I've collect about this. Of course they keep moving settings around.
    As you have noticed.

    Now there are "Buffer sizes"/Min frames/Max frames settings. No idea if this is video or audio frames.
    Experiment and see how it goes.

    Right now "TS mux rate" "Advanced Profile Options" is popping into my head...something to check maybe.

    VRD is a 32 bit program so is very memory limited.
    I started upping Buffers/caches and such a lot and ran into problems
    and had to back down.

    Keep hoping V6 will be 64 bit but not holding breath!

    -----------------------------Old info---------------------------------------------------------
    Video Ring Buffer Overflow

    This error generally indicates a very severe problem, with your source file. I.e. audio is missing for multiple seconds. Here are some solutions (probably best to apply one at a time).

    1. Have you tried running Tools>QuickStream Fix first?

    2. On the Tools>Options>Stream Parameters page, make sure the "Double Video Buffer Memory" is checked. (You've done this already.)

    ---------------Ok this is not at 13,14-------------------------------------- 8Aug2018
    3. If that doesn't work, try increasing the buffer sizes to 1024 for audio and video. To increase the buffer sizes, click on the menu Tools>Shift+Options. The buffer sizes are items #13 and #14 on this screen. Set them to 1024 each and then restart VideoReDo and give it a try. It will consume lots of memory and slow down editing so you may want to set it back later if it is only this one file.

    4. Look at the VideoReDo.log file (Help>Display Log). The log will show you where in the source file the problem occurs. Perhaps you can manually cut the section.
    --------------------------------------------------------
    Last edited by jmc; August 8th, 2018 at 01:10 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •